Discussion:
Bug#868322: nginx: jessie-backports version depends on unavailable libssl1.1
Add Reply
Sylvan Heuser
2017-07-14 13:40:01 UTC
Reply
Permalink
Raw Message
Package: nginx
Version: 1.10.3-1+deb9u1~bpo8+1
Severity: important

Dear Maintainer,

I was trying to install nginx from the jessie-backports repository, but the package there depends on libssl1.1, which is not present in jessie nor jessie-backports. This means I cannot install the backported version on my system.

I expected the backports version to be built so it can be installed in a standard Jessie system, i.e. have no unresolvable dependencies.

-- System Information:
Debian Release: 8.8
APT prefers oldstable
APT policy: (500, 'oldstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
Christos Trochalakis
2017-07-14 15:40:02 UTC
Reply
Permalink
Raw Message
There were two consecutive uploads to solve this, the correct one is
1.10.3-1+deb9u1~bpo8+2, eventually it will reach all the mirrors.
Sorry for the inconvience.
Post by Sylvan Heuser
Package: nginx
Version: 1.10.3-1+deb9u1~bpo8+1
Severity: important
Dear Maintainer,
I was trying to install nginx from the jessie-backports repository, but the package there depends on libssl1.1, which is not present in jessie nor jessie-backports. This means I cannot install the backported version on my system.
I expected the backports version to be built so it can be installed in a standard Jessie system, i.e. have no unresolvable dependencies.
Debian Release: 8.8
APT prefers oldstable
APT policy: (500, 'oldstable')
Architecture: amd64 (x86_64)
Kernel: Linux 3.16.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
_______________________________________________
Pkg-nginx-maintainers mailing list
https://lists.alioth.debian.org/mailman/listinfo/pkg-nginx-maintainers
Sýlvan Heuser - FLEXOPTIX
2017-07-17 09:30:02 UTC
Reply
Permalink
Raw Message
No problem, after waiting quite some time and enjoying the weekend, I can now confirm that even my mirror (whichever one hides
behind deb.debian.org right now) received the latest update and setting up new machines works flawlessly. :-)
Post by Christos Trochalakis
There were two consecutive uploads to solve this, the correct one is
1.10.3-1+deb9u1~bpo8+2, eventually it will reach all the mirrors.
Sorry for the inconvience.
Post by Sylvan Heuser
Package: nginx
Version: 1.10.3-1+deb9u1~bpo8+1
Dear Maintainer,
I was trying to install nginx from the jessie-backports repository, but the package there depends on libssl1.1, which is not
present in jessie nor jessie-backports. This means I cannot install the backported version on my system.
I expected the backports version to be built so it can be installed in a standard Jessie system, i.e. have no unresolvable
dependencies.
[
]
--
SÃœlvan Heuser
Developer

Flexoptix GmbH
Waldstr. 92
63128 Dietzenbach

Phone: +49 6074 2151 2040
Fax: +49 6074 2151 2049
E-Mail: ***@flexoptix.net
Web: https://www.flexoptix.net

Sitz: 63128 Dietzenbach, Registergericht: Offenbach a.M.
HRB 43289, USt.-Id.-Nr.: DE258020410, WEEE-Reg.-Nr.: DE19255147
GeschÀftsfÌhrung: Markus Arnold, Hubert Potthoff, Thomas Weible, Stephan Werner
Loading...