Discussion:
Bug#928442: clonezilla: debian-live clonezilla fails to infinate loop while scanning /tmp/ocs_bind_root
(too old to reply)
Debian Live user
2019-05-04 18:40:01 UTC
Permalink
Package: clonezilla
Version: 3.27.16-3
Severity: important

Dear Maintainer,

debian-live clonezilla fails to infinate loop while scanning /tmp/ocs_bind_root

reproduce,

boot debian-live-buster-DI-rc1-amd64-kde+nonfree.iso
sudo apt update
sudo apt install clonezilla

sudo clonezilla
device-image
local_dev
Enter
select drive for image repository
clonezilla fails to infinate loop
I've tried various versions of the buster live-cd in Virtualbox and bare metal with the same results.


-- System Information:
Debian Release: buster/sid
APT prefers testing
APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE= (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages clonezilla depends on:
ii bc 1.07.1-2+b1
ii dialog 1.3-20190211-1
ii drbl 2.20.11-7
ii e2fsprogs 1.44.5-1
ii fdisk 2.33.1-0.1
ii file 1:5.35-4
ii gdisk 1.0.3-1.1
ii pigz 2.4-1
ii util-linux 2.33.1-0.1

Versions of packages clonezilla recommends:
ii partclone 0.3.11-1+b3
pn partimage <none>

Versions of packages clonezilla suggests:
pn cifs-utils <none>
ii openssh-client 1:7.9p1-10
ii sshfs 2.10+repack-2
pn udpcast <none>

-- no debconf information
RattusSolarus
2019-12-03 01:10:02 UTC
Permalink
I'm having what appears to be exactly the same issue running Clonezilla
in Buster installed to SSD in 2 separate computers.

Clonezilla version: 3.27.16-3
Daniel Fishman
2020-01-22 15:50:01 UTC
Permalink
The issue described in this bug report is caused by wrong depencies
for the package, in particular: clonezilla depends on drbl (>> 2.20.11-5),
and right now a version of drbl in stable/testing/unstable is 2.20.11-7.
But this version is too old, and it misses some important pieces which
are needed for the current version of clonezilla to work correctly.

A proper solution for this problem requires update of drbl package
to a newer version, compatible with the current clonezilla version.

As a temporal workaround it is possible to install the latest version
of the drbl package provided by the developers from here:

http://free.nchc.org.tw/drbl-core/pool/drbl/stable/drbl/

For example, 2.30.5 works for me in buster.


In particular, the exact problem described in the bug is caused by
an undefined bash variable $msg_exit_browsing. It is used in
ocs-functions script to build a dialog with a whiptail command which
is then evaluated, and user's choice in the dialog (which is supposed
to be a path) is then used as an argument to 'cd' command in the line
shown in a screenshot from message #10.
But $msg_exit_browsing is not defined and therefore it's evaluation
results in nothing, but whiptail misses the expected argument and
therefore instead of returning user's choice it prints out usage
help (which is what we see in the screenshot). And using this
output instead of the expected directory path causes the problem.

In turn, values for all $msg_* variables are defined in files
located in a /usr/share/drbl/lang/bash/ directory. But $msg_exit_browsing
still still not present in drbl 2.20.11, therefore is the compatibility
problem.

Loading...