Discussion:
Bug#891624: Please drop libpcre2-dbg package and rely on -dbgsyms ones
Add Reply
Laurent Bigonville
2018-02-27 11:50:01 UTC
Reply
Permalink
Source: pcre2
Version: 10.31-2
Severity: wishlist

Hi,

Currently libpcre2-dbg package pulls all the "flavour" of libpcre2

IMHO, the libpcre2-dbg should be dropped, -dbgsyms package are built
automatically these days per package.

Kind regards,

Laurent Bigonville

-- System Information:
Debian Release: buster/sid
APT prefers unstable-debug
APT policy: (500, 'unstable-debug'), (500, 'unstable'), (1, 'experimental-debug'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.15.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_BE.UTF-8, LC_CTYPE=fr_BE.UTF-8 (charmap=UTF-8), LANGUAGE=fr_BE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: SELinux: enabled - Mode: Permissive - Policy name: refpolicy

Versions of packages libpcre2-dbg depends on:
ii libpcre2-16-0 10.31-2
ii libpcre2-32-0 10.31-2
ii libpcre2-8-0 10.31-2
ii libpcre2-posix0 10.31-2

libpcre2-dbg recommends no packages.

libpcre2-dbg suggests no packages.

-- no debconf information
Michael Biebl
2019-12-01 16:10:01 UTC
Reply
Permalink
Control: tags -1 + patch

Attached is a trivial patch to make the switch to dbgsym
It assumes that the next uploaded version will be 10.34-2
--
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?
Matthew Vernon
2019-12-02 10:10:02 UTC
Reply
Permalink
Post by Michael Biebl
Control: tags -1 + patch
Attached is a trivial patch to make the switch to dbgsym
It assumes that the next uploaded version will be 10.34-2
Thanks for the poke (and patch); I'll get this in the next upload.

Regards,

Matthew

Loading...