Discussion:
Bug#943692: squid: crash on bug #4823 : assertion failed: stmem.cc:98: "lowestOffset () <= target_offset"
(too old to reply)
Santiago García Mantiñán
2019-10-28 07:50:01 UTC
Permalink
Package: squid
Version: 4.6-1+deb10u1
Severity: important
Tags: patch

Dear Maintainer,

Shortly after buster came out I updated the machines to it and after a
little time we found out that squid had crashed with owestOffset () <= target_offset

Amos was so kind to point me to bug #4823 on squid:
https://bugs.squid-cache.org/show_bug.cgi?id=4823

And after adding the patch from
http://www.squid-cache.org/Versions/v4/changesets/squid-4-10b699c30ef575d97e093d344ff85771654e7d8c.patch
to the Debian source package and compiling it the system became stable and
hasn't crashed anymore.

I suggest we add that for the next point release.

Thanks.

-- System Information:
Debian Release: 10.1
APT prefers stable
APT policy: (990, 'stable'), (500, 'stable-updates'), (500, 'oldoldstable'), (500, 'unstable'), (500, 'oldstable'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-6-amd64 (SMP w/2 CPU cores)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=gl_ES.UTF-8, LC_CTYPE=gl_ES.UTF-8 (charmap=UTF-8), LANGUAGE=gl_ES.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages squid depends on:
ii adduser 3.118
ii libc6 2.28-10
ii libcap2 1:2.25-2
ii libcom-err2 1.44.5-1+deb10u2
ii libdb5.3 5.3.28+dfsg1-0.5
ii libdbi-perl 1.642-1+b1
ii libecap3 1.0.1-3.2
ii libexpat1 2.2.6-2+deb10u1
ii libgcc1 1:8.3.0-6
ii libgnutls30 3.6.7-4
ii libgssapi-krb5-2 1.17-3
ii libkrb5-3 1.17-3
ii libldap-2.4-2 2.4.47+dfsg-3+deb10u1
ii libltdl7 2.4.6-9
ii libnetfilter-conntrack3 1.0.7-1
ii libnettle6 3.4.1-1
ii libpam0g 1.3.1-5
ii libsasl2-2 2.1.27+dfsg-1
ii libstdc++6 8.3.0-6
ii libxml2 2.9.4+dfsg1-7+b3
ii logrotate 3.14.0-4
ii lsb-base 10.2019051400
ii netbase 5.6
ii squid-common 4.6-1+deb10u1

Versions of packages squid recommends:
ii ca-certificates 20190110
ii libcap2-bin 1:2.25-2

Versions of packages squid suggests:
pn resolvconf <none>
ii smbclient 2:4.9.5+dfsg-5+deb10u1
pn squid-cgi <none>
pn squid-purge <none>
pn squidclient <none>
pn ufw <none>
pn winbind <none>

-- no debconf information
Matus UHLAR - fantomas
2019-11-08 08:10:01 UTC
Permalink
Hello,

I have the same problem with squid 4.6-1+deb10u1.
I have applied the patch mentioned and it fixed the problem.

http://www.squid-cache.org/Versions/v4/changesets/squid-4-10b699c30ef575d97e093d344ff85771654e7d8c.patch

Please, update the version in debian.
Thank you.
--
Matus UHLAR - fantomas, ***@fantomas.sk ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
10 GOTO 10 : REM (C) Bill Gates 1998, All Rights Reserved!
Matus UHLAR - fantomas
2019-11-12 13:00:02 UTC
Permalink
Thank you. Is it possible to push patched version to buster?
Seems that we have just missed point release :-(
--
Matus UHLAR - fantomas, ***@fantomas.sk ; http://www.fantomas.sk/
Warning: I wish NOT to receive e-mail advertising to this address.
Varovanie: na tuto adresu chcem NEDOSTAVAT akukolvek reklamnu postu.
42.7 percent of all statistics are made up on the spot.
Loading...