Discussion:
Bug#933303: gnome-control-center: Google Online Account setup crashes under Wayland
Add Reply
Nathan A. Stine
2019-07-28 22:20:02 UTC
Reply
Permalink
Package: gnome-control-center
Version: 1:3.30.3-1
Severity: normal

Dear Maintainer,

* What led up to the situation?

I ran gnome-control-center in a terminal window and then went to Online
Accounts and then Google under Add an account. The program crashed with this
error:

Gdk-Message: 18:04:35.031: Error 71 (Protocol error) dispatching to Wayland
display.

* What exactly did you do (or not do) that was effective (or ineffective)?

I ran "GDK_BACKEND=x11 gnome-control-center" in the terminal and followed the
same steps.

* What was the outcome of this action?

I was successfully able to add my Google accounts.



-- System Information:
Debian Release: 10.0
APT prefers stable
APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gnome-control-center depends on:
ii accountsservice 0.6.45-2
ii apg 2.2.3.dfsg.1-5
ii colord 1.4.3-4
ii desktop-base 10.0.2
ii desktop-file-utils 0.23-4
ii gnome-control-center-data 1:3.30.3-1
ii gnome-desktop3-data 3.30.2.1-2
ii gnome-settings-daemon 3.30.2-3
ii gsettings-desktop-schemas 3.28.1-1
ii libaccountsservice0 0.6.45-2
ii libatk1.0-0 2.30.0-2
ii libc6 2.28-10
ii libcairo-gobject2 1.16.0-4
ii libcairo2 1.16.0-4
ii libcanberra-gtk3-0 0.30-7
ii libcanberra0 0.30-7
ii libcheese-gtk25 3.31.90-1
ii libcheese8 3.31.90-1
ii libclutter-1.0-0 1.26.2+dfsg-10
ii libclutter-gtk-1.0-0 1.8.4-4
ii libcolord-gtk1 0.1.26-2
ii libcolord2 1.4.3-4
ii libcups2 2.2.10-6
ii libfontconfig1 2.13.1-2
ii libgdk-pixbuf2.0-0 2.38.1+dfsg-1
ii libglib2.0-0 2.58.3-2
ii libgnome-bluetooth13 3.28.2-3
ii libgnome-desktop-3-17 3.30.2.1-2
ii libgoa-1.0-0b 3.30.1-2
ii libgoa-backend-1.0-1 3.30.1-2
ii libgrilo-0.3-0 0.3.7-1
ii libgtk-3-0 3.24.5-1
ii libgtop-2.0-11 2.38.0-4
ii libgudev-1.0-0 232-2
ii libibus-1.0-5 1.5.19-4
ii libkrb5-3 1.17-3
ii libmm-glib0 1.10.0-1
ii libnm0 1.14.6-2
ii libnma0 1.8.20-1.1
ii libpango-1.0-0 1.42.4-6
ii libpangocairo-1.0-0 1.42.4-6
ii libpolkit-gobject-1-0 0.105-25
ii libpulse-mainloop-glib0 12.2-4
ii libpulse0 12.2-4
ii libpwquality1 1.4.0-3
ii libsecret-1-0 0.18.7-1
ii libsmbclient 2:4.9.5+dfsg-5
ii libsoup2.4-1 2.64.2-2
ii libupower-glib3 0.99.10-1
ii libwacom2 0.32-1
ii libwayland-server0 1.16.0-1
ii libx11-6 2:1.6.7-1
ii libxi6 2:1.7.9-1
ii libxml2 2.9.4+dfsg1-7+b3

Versions of packages gnome-control-center recommends:
ii cracklib-runtime 2.9.6-2
ii cups-pk-helper 0.2.6-1+b1
ii gkbd-capplet 3.26.1-1
ii gnome-online-accounts 3.30.1-2
ii gnome-user-docs 3.30.2-1
ii gnome-user-share 3.28.0-2
ii iso-codes 4.2-1
ii libcanberra-pulse 0.30-7
ii libnss-myhostname 241-5
ii mousetweaks 3.12.0-5
ii network-manager-gnome 1.8.20-1.1
ii policykit-1 0.105-25
ii pulseaudio-module-bluetooth 12.2-4
ii realmd 0.16.3-2
ii rygel 0.36.2-4
ii rygel-tracker 0.36.2-4
ii system-config-printer-common 1.5.11-4

Versions of packages gnome-control-center suggests:
ii gnome-software 3.30.6-5
ii gstreamer1.0-pulseaudio 1.14.4-1
pn libcanberra-gtk-module <none>
ii libcanberra-gtk3-module 0.30-7
ii x11-xserver-utils 7.7+8

-- no debconf information
Nathan A. Stine
2019-08-11 21:20:01 UTC
Reply
Permalink
Package: gnome-control-center
Version: 1:3.30.3-1
Followup-For: Bug #933303

I have noticed that several applications are giving similar errors. I ran
"WAYLAND_DEBUG=1 gnome-control-center" and received this line in the terminal
output just before the crash:

***@1.error(nil, 7, "failed to import supplied dmabufs: Unsupported
buffer format 808665665")

Perhaps this will be helpful in diagnosing the problem.

Nathan A. Stine



-- System Information:
Debian Release: 10.0
APT prefers stable
APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages gnome-control-center depends on:
ii accountsservice 0.6.45-2
ii apg 2.2.3.dfsg.1-5
ii colord 1.4.3-4
ii desktop-base 10.0.2
ii desktop-file-utils 0.23-4
ii gnome-control-center-data 1:3.30.3-1
ii gnome-desktop3-data 3.30.2.1-2
ii gnome-settings-daemon 3.30.2-3
ii gsettings-desktop-schemas 3.28.1-1
ii libaccountsservice0 0.6.45-2
ii libatk1.0-0 2.30.0-2
ii libc6 2.28-10
ii libcairo-gobject2 1.16.0-4
ii libcairo2 1.16.0-4
ii libcanberra-gtk3-0 0.30-7
ii libcanberra0 0.30-7
ii libcheese-gtk25 3.31.90-1
ii libcheese8 3.31.90-1
ii libclutter-1.0-0 1.26.2+dfsg-10
ii libclutter-gtk-1.0-0 1.8.4-4
ii libcolord-gtk1 0.1.26-2
ii libcolord2 1.4.3-4
ii libcups2 2.2.10-6
ii libfontconfig1 2.13.1-2
ii libgdk-pixbuf2.0-0 2.38.1+dfsg-1
ii libglib2.0-0 2.58.3-2
ii libgnome-bluetooth13 3.28.2-3
ii libgnome-desktop-3-17 3.30.2.1-2
ii libgoa-1.0-0b 3.30.1-2
ii libgoa-backend-1.0-1 3.30.1-2
ii libgrilo-0.3-0 0.3.7-1
ii libgtk-3-0 3.24.5-1
ii libgtop-2.0-11 2.38.0-4
ii libgudev-1.0-0 232-2
ii libibus-1.0-5 1.5.19-4
ii libkrb5-3 1.17-3
ii libmm-glib0 1.10.0-1
ii libnm0 1.14.6-2
ii libnma0 1.8.20-1.1
ii libpango-1.0-0 1.42.4-6
ii libpangocairo-1.0-0 1.42.4-6
ii libpolkit-gobject-1-0 0.105-25
ii libpulse-mainloop-glib0 12.2-4
ii libpulse0 12.2-4
ii libpwquality1 1.4.0-3
ii libsecret-1-0 0.18.7-1
ii libsmbclient 2:4.9.5+dfsg-5
ii libsoup2.4-1 2.64.2-2
ii libupower-glib3 0.99.10-1
ii libwacom2 0.32-1
ii libwayland-server0 1.16.0-1
ii libx11-6 2:1.6.7-1
ii libxi6 2:1.7.9-1
ii libxml2 2.9.4+dfsg1-7+b3

Versions of packages gnome-control-center recommends:
ii cracklib-runtime 2.9.6-2
ii cups-pk-helper 0.2.6-1+b1
ii gkbd-capplet 3.26.1-1
ii gnome-online-accounts 3.30.1-2
ii gnome-user-docs 3.30.2-1
ii gnome-user-share 3.28.0-2
ii iso-codes 4.2-1
ii libcanberra-pulse 0.30-7
ii libnss-myhostname 241-5
ii mousetweaks 3.12.0-5
ii network-manager-gnome 1.8.20-1.1
ii policykit-1 0.105-25
ii pulseaudio-module-bluetooth 12.2-4
ii realmd 0.16.3-2
ii rygel 0.36.2-4
ii rygel-tracker 0.36.2-4
ii system-config-printer-common 1.5.11-4

Versions of packages gnome-control-center suggests:
ii gnome-software 3.30.6-5
ii gstreamer1.0-pulseaudio 1.14.4-1
pn libcanberra-gtk-module <none>
ii libcanberra-gtk3-module 0.30-7
ii x11-xserver-utils 7.7+8

-- no debconf information

Loading...