Discussion:
Bug#948769: avogadrolibs: does not depend on libopenbabel-dev
Add Reply
Drew Parsons
2020-01-13 16:10:01 UTC
Reply
Permalink
Source: avogadrolibs
Followup-For: Bug #948769

avogadrolibs depends on the openbabel plugin libraries and datafiles
in /usr/lib/openbabel/ and /usr/share/openbabel, see ll.60,68 in
avogadro/qtplugins/openbabel/obprocess.cpp

Strictly speaking these are provided by libopenbabel5, but it is
cleaner I think to have avogadrolibs depend on libopenbabel-dev, which
depends on libopenbabel5 (or on its successors, when openbabel updates
its ABI).
Drew Parsons
2020-01-14 01:30:02 UTC
Reply
Permalink
Source: avogadrolibs
Followup-For: Bug #948769

Actually openbabel is the proper dependency here rather than
libopenbabel-dev.

avogadrolibs does need openbabel (invokes obabel), and openbabel pulls
in libopenbabel5.

Loading...