Discussion:
Bug#932409: libconfig-model-dpkg-perl: When the installed debian-policy is older than the hardcoded one, the error message is unhelpful
(too old to reply)
Clément Hermann
2019-07-18 21:50:01 UTC
Permalink
Package: libconfig-model-dpkg-perl
Version: 2.122
Severity: normal

While running dh-make-perl (0.106, not uploaded yet) for a new package,
with an out-of-date policy installed (4.3.0 instead of 4.4.0), I got the
following error:

```
Warning in 'source Standards-Version': Current standards version is '4.3.0'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.4.0' to '4.3.0'.

Offending value: '4.4.0'
```

while it is true that there is an issue on my system (I should have made
sure the latest policy version was installed), the message is quite
bizarre and unhelpful ;)

Idealy, we whould check if the installed version is older than the
hardcoded version and warn the user about the outdated local version and
not ask him to check for "upgrades" in policy ;)

Cheers,
--
nodens

-- System Information:
Debian Release: 10.0
APT prefers unstable
APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-5-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8), LANGUAGE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libconfig-model-dpkg-perl depends on:
ii libapt-pkg-perl 0.1.36+b1
ii libarray-intspan-perl 2.003-1
ii libconfig-model-backend-yaml-perl 2.133-2
ii libconfig-model-perl 2.133-1
ii libexporter-lite-perl 0.08-1
ii liblog-log4perl-perl 1.49-1
pn libmodule-corelist-perl <none>
ii libmouse-perl 2.5.6-1+b1
ii libparse-recdescent-perl 1.967015+dfsg-2
ii libsoftware-licensemoreutils-perl 1.004-1
ii libtext-autoformat-perl 1.740000-2
ii libtext-levenshtein-damerau-perl 0.41-1
ii liburi-perl 1.76-1
ii libwww-perl 6.36-2
ii libyaml-perl 1.27-1
ii licensecheck 3.0.31-3
ii lintian 2.15.0
ii perl 5.28.1-6

Versions of packages libconfig-model-dpkg-perl recommends:
ii libconfig-model-tkui-perl 1.369-2

libconfig-model-dpkg-perl suggests no packages.

-- no debconf information
Dominique Dumont
2019-07-21 17:10:01 UTC
Permalink
On Thu, 18 Jul 2019 18:45:26 -0300 =?utf-8?q?Cl=C3=A9ment_Hermann?=
Post by Clément Hermann
while it is true that there is an issue on my system (I should have made
sure the latest policy version was installed), the message is quite
bizarre and unhelpful ;)
Idealy, we whould check if the installed version is older than the
hardcoded version and warn the user about the outdated local version and
not ask him to check for "upgrades" in policy ;)
Fair enough.

Next version will show this kind of message in a similar situation:

Warning in 'control source Standards-Version': Current standards version
'1000.1.1' is newer than lintian version (4.4.0). Please check your system

Is this fine with you ?

All the best

Dod

Loading...