Discussion:
Bug#948511: libtool: Would FTBFS with new gnulib snapshot (20200105)
(too old to reply)
Boyuan Yang
2020-01-09 16:20:02 UTC
Permalink
Source: libtool
Severity: important
Version: 2.4.6-11

Dear libtool maintainer,

During a rebuild test of all gnulib reverse build-dependencies, your package
(libtool) will FTBFS with the new snapshot of gnulib (
https://tracker.debian.org/pkg/gnulib , currently in experimental). The build
log is provided in the attachment.

The build log suggests that the error lies in a version check for autoconf. I
haven't dug into it but the fix should be trivial once the FTBFS cause is
found.
--
Thanks,
Boyuan Yang
Boyuan Yang
2020-01-14 03:50:01 UTC
Permalink
Looks like it was due to libtool's configure.ac setting AC_PREREQ to be 2.62,
which is below the new gnulib's minimum version requirement (2.63).

The version requirement should not cause any trouble since Debian has been
shipping autoconf 2.63+ for over 10 years. However, I'd like to keep this bug
open until libtool upstream has raised the autoconf version requirement.
Before that, I will patch gnulib and accept the 2.62 version string for now.

Thanks,
Boyuan Yang
Post by Boyuan Yang
Source: libtool
Severity: important
Version: 2.4.6-11
Dear libtool maintainer,
During a rebuild test of all gnulib reverse build-dependencies, your package
(libtool) will FTBFS with the new snapshot of gnulib (
https://tracker.debian.org/pkg/gnulib , currently in experimental). The build
log is provided in the attachment.
The build log suggests that the error lies in a version check for autoconf. I
haven't dug into it but the fix should be trivial once the FTBFS cause is
found.
Loading...