Discussion:
Bug#941580: cups-filters: Fails to print in Canon iRC2380i (foomatic/pxlcolor for C2550) with new ghostscript 9.28~~rc3~dfsg-1
Add Reply
Agustin Martin
2019-10-02 11:50:01 UTC
Reply
Permalink
Package: cups-filters
Version: 1.25.6-1
Severity: normal

Hi,

Since last ghostscript upgrade (9.28~~rc3~dfsg-1) I cannot print to our
Canon imageRunner iRC2380i with the recommended foomatic/pxlcolor choice.
It worked previously (although only B&W), but now it is failing, printing
only

PCL XL Error
Subsystem: IMAGE
Error: ExtraData
Operator: ReadImage
Position: 876

If I downgrade ghostscript, libgs9 and ligbs9-common to testing versions
(9.27~dfsg-3.1), B&W printing works again.

Do not know if filters need to be upgraded for something new in ghostscript,
so I am filing this bug report against cups-filters, and not against
ghostscript. Please reassign if appropriate.

Thanks in advance,

Regards.

-- System Information:
Debian Release: bullseye/sid
APT prefers unstable
APT policy: (500, 'unstable'), (500, 'testing'), (200, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 5.2.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=es_ES.utf8, LC_CTYPE=es_ES.utf8 (charmap=UTF-8), LANGUAGE=es_ES.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages cups-filters depends on:
ii bc 1.07.1-2+b2
ii cups-filters-core-drivers 1.25.6-1
ii ghostscript 9.28~~rc3~dfsg-1
ii libc6 2.29-2
ii libcups2 2.3.0-5
ii libcupsfilters1 1.25.6-1
ii libfontconfig1 2.13.1-2+b1
ii libfontembed1 1.25.6-1
ii libgcc1 1:9.2.1-8
ii libqpdf26 9.0.1-1+b1
ii libstdc++6 9.2.1-8
ii poppler-utils 0.71.0-5+b1

Versions of packages cups-filters recommends:
ii colord 1.4.4-1
ii liblouis-bin 3.11.0-2
ii liblouisutdml-bin 2.8.0-2

Versions of packages cups-filters suggests:
ii antiword 0.37-15
pn docx2txt <none>
ii foomatic-db 20190913-1
ii imagemagick 8:6.9.10.23+dfsg-2.1+b1
ii imagemagick-6.q16 [imagemagick] 8:6.9.10.23+dfsg-2.1+b1

-- no debconf information
--
Agustin
Michael Schütz
2019-10-09 11:10:02 UTC
Reply
Permalink
Hi,

I had a similar issue. After upgrading to 'buster' my printer doesn't
work. After downgrade ghostscript, libgs9 and libgs9-common to version
from oldstable (ghostscript 9.26) everything is running as usual.

Schultze
--
Der Politiker denkt an die nächsten Wahlen, der Staatsmann an die
nächste Generation.
William Ewart Gladstone
Jonas Smedegaard
2019-10-09 12:00:01 UTC
Reply
Permalink
[ re-sending with ASCII headers to please Debian mailservers ]

Hi Michael,

Quoting Michael SchÃŒtz (2019-10-09 12:56:52)
Post by Michael Schütz
I had a similar issue. After upgrading to 'buster' my printer doesn't
work. After downgrade ghostscript, libgs9 and libgs9-common to version
from oldstable (ghostscript 9.26) everything is running as usual.
Please file a separate bugreport with the details of your encounter.
Prefarably file the bugreport against the printer driver you use.

Similarly looking bugs can have different causes, and specifically in
the area of recent Ghostscript changes the causes was likely _triggered_
by changes in Ghostscript (tightening of previously insecure processing)
which needs to be _fixes_ in various different packages where that code
is being passed to Ghostscript.

Kind regards,

- Jonas
--
* Jonas Smedegaard - idealist & Internet-arkitekt
* Tlf.: +45 40843136 Website: http://dr.jones.dk/

[x] quote me freely [ ] ask before reusing [ ] keep private
Agustin Martin
2019-12-02 10:40:01 UTC
Reply
Permalink
Source: ghostscript
Source-Version: 9.50~dfsg-5
We believe that the bug you reported is fixed in the latest version of
ghostscript, which is due to be installed in the Debian FTP archive.
ghostscript (9.50~dfsg-5) unstable; urgency=medium
.
* add patch cherry-picked upstream
to add 'omitEOD' flag to RLE compressor and use for PXL;
closes: bug#941864,
Thanks, Jonas,

Fix is working well here.
--
Agustin
Jonas Smedegaard
2019-12-02 11:10:01 UTC
Reply
Permalink
Quoting Agustin Martin (2019-12-02 11:17:04)
Post by Agustin Martin
Source: ghostscript
Source-Version: 9.50~dfsg-5
We believe that the bug you reported is fixed in the latest version of
ghostscript, which is due to be installed in the Debian FTP archive.
ghostscript (9.50~dfsg-5) unstable; urgency=medium
.
* add patch cherry-picked upstream
to add 'omitEOD' flag to RLE compressor and use for PXL;
closes: bug#941864,
Thanks, Jonas,
Fix is working well here.
Good to know - thanks for the confirmation.

...and sorry for my lack of response in the process :-/

- Jonas
--
* Jonas Smedegaard - idealist & Internet-arkitekt
* Tlf.: +45 40843136 Website: http://dr.jones.dk/

[x] quote me freely [ ] ask before reusing [ ] keep private
Loading...