Discussion:
Bug#941365: buster-pu: package libimobiledevice/1.2.1~git20181030.92c5462-2
Add Reply
Yves-Alexis Perez
2019-09-29 17:00:02 UTC
Reply
Permalink
Package: release.debian.org
Severity: normal
Tags: buster
User: ***@packages.debian.org
Usertags: pu

Hi,

libimobiledevice in Buster has some issue with devices running iOS 13+.
Backup using idevicebackup2 never finishes, apparently because of some
behavior change in newer iOS version.

With coordination with upstream
(https://github.com/libimobiledevice/libimobiledevice/issues/848) a
small fix was identified.

Would it be possible to upload a fixed package to Buster at some point?
The fix is not yet in sid (a previous package is waiting in NEW, I'll
upload a package fix soon) so it's more a pre-approval.

The debdiff is attached for review.

Thanks in advance,
--
Yves-Alexis

-- System Information:
Debian Release: bullseye/sid
APT prefers unstable-debug
APT policy: (500, 'unstable-debug'), (500, 'unstable'), (450, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.2.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8), LANGUAGE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled
Adam D. Barratt
2019-11-08 21:00:02 UTC
Reply
Permalink
Control: tags -1 + moreinfo
Post by Yves-Alexis Perez
libimobiledevice in Buster has some issue with devices running iOS
13+. Backup using idevicebackup2 never finishes, apparently because
of some behavior change in newer iOS version.
With coordination with upstream
(https://github.com/libimobiledevice/libimobiledevice/issues/848) a
small fix was identified.
Would it be possible to upload a fixed package to Buster at some point?
The fix is not yet in sid (a previous package is waiting in NEW, I'll
upload a package fix soon) so it's more a pre-approval.
Sorry for the delay in getting back to you.

That sounds OK, but it looks like the fix still hasn't made it to sid,
so I'm tagging this as moreinfo for now. Please remove the tag and
confirm the final debdiff once that's sorted.

Regards,

Adam
Yves-Alexis Perez
2019-11-08 21:00:02 UTC
Reply
Permalink
Post by Adam D. Barratt
Sorry for the delay in getting back to you.
Yeah, this time it's me who's really sorry.
Post by Adam D. Barratt
That sounds OK, but it looks like the fix still hasn't made it to sid,
so I'm tagging this as moreinfo for now. Please remove the tag and
confirm the final debdiff once that's sorted.
Indeed, I'm still waiting on upstream to actually chose the way they bump the
soname… I still don't have any answer on
https://github.com/libimobiledevice/libusbmuxd/issues/81

I'll keep you posted as soon as possible.

Regards,
- --
Yves-Alexis
Yves-Alexis Perez
2019-11-22 16:40:02 UTC
Reply
Permalink
Post by Yves-Alexis Perez
Post by Adam D. Barratt
Sorry for the delay in getting back to you.
Yeah, this time it's me who's really sorry.
Post by Adam D. Barratt
That sounds OK, but it looks like the fix still hasn't made it to sid,
so I'm tagging this as moreinfo for now. Please remove the tag and
confirm the final debdiff once that's sorted.
Indeed, I'm still waiting on upstream to actually chose the way they bump the
soname… I still don't have any answer on
https://github.com/libimobiledevice/libusbmuxd/issues/81
I'll keep you posted as soon as possible.
Sorry, I replied to the wrong bug. I'll upload the isolated fix soon, likely
this weekend, thanks.

Regards,
- --
Yves-Alexis
Adam D. Barratt
2019-12-07 20:20:02 UTC
Reply
Permalink
Post by Yves-Alexis Perez
Post by Yves-Alexis Perez
Post by Adam D. Barratt
Sorry for the delay in getting back to you.
Yeah, this time it's me who's really sorry.
Post by Adam D. Barratt
That sounds OK, but it looks like the fix still hasn't made it to sid,
so I'm tagging this as moreinfo for now. Please remove the tag and
confirm the final debdiff once that's sorted.
Indeed, I'm still waiting on upstream to actually chose the way
they bump
the
soname… I still don't have any answer on
https://github.com/libimobiledevice/libusbmuxd/issues/81
I'll keep you posted as soon as possible.
Sorry, I replied to the wrong bug. I'll upload the isolated fix soon,
likely this weekend, thanks.
Just to keep this up-to-date, the libimobiledevice upload made it to
sid, but is blocked by python3-plist needing to make it out of NEW.

Regards,

Adam

Loading...