Discussion:
Bug#948513: auto-multiple-choice-common: Should depend on liblocale-codes-perl
Add Reply
Michal Sojka
2020-01-09 16:40:02 UTC
Reply
Permalink
Package: auto-multiple-choice-common
Version: 1.4.0-2
Severity: normal

Dear Maintainer,

when I run auto-multiple-choice, I get the following error:

Can't locate Locale/Language.pm in @INC (you may need to install
the Locale::Language module) (@INC contains: /etc/perl
/usr/local/lib/x86_64-linux-gnu/perl/5.30.0
/usr/local/share/perl/5.30.0 /usr/lib/x86_64-linux-gnu/perl5/5.30
/usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.30
/usr/share/perl/5.30 /usr/local/lib/site_perl
/usr/lib/x86_64-linux-gnu/perl-base) at
/usr/lib/AMC/perl/AMC-gui.pl line 43.
BEGIN failed--compilation aborted at /usr/lib/AMC/perl/AMC-gui.pl line 43.

I was able to get rid of it by manually installing
liblocale-codes-perl so I think that auto-multiple-choice-common
should depend on this package.

-- System Information:
Debian Release: bullseye/sid
APT prefers unstable-debug
APT policy: (500, 'unstable-debug'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.3.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages auto-multiple-choice-common depends on:
ii ghostscript 9.50~dfsg-5
ii imagemagick 8:6.9.10.23+dfsg-2.1+b2
ii imagemagick-6.q16 [imagemagick] 8:6.9.10.23+dfsg-2.1+b2
ii libarchive-zip-perl 1.67-1
ii libclone-perl 0.43-2
ii libdbd-sqlite3-perl 1.64-1+b1
ii libdbi-perl 1.642-1+b2
ii libfile-mimeinfo-perl 0.29-1
ii libglib-object-introspection-perl 0.048-1
ii libgraphics-magick-perl 1.4+really1.3.33+hg16117-1
ii libgtk3-perl 0.036-1
ii liblocale-codes-perl 3.62-1
ii liblocale-gettext-perl 1.07-4
ii libperl5.22 [libio-compress-perl] 5.22.2-5
ii librsvg2-common 2.46.4-1
ii libtext-csv-perl 2.00-1
ii libxml-simple-perl 2.25-1
ii libxml-writer-perl 0.625-1
ii netpbm 2:10.0-15.3+b2
ii perl [libio-compress-perl] 5.30.0-9
ii perl-modules-5.22 [liblocale-codes-perl] 5.22.2-5
ii poppler-utils 0.71.0-6
ii tex-common 6.13
ii texlive-fonts-extra 2019.20191208-1
ii texlive-fonts-recommended 2019.20191208-4
ii texlive-latex-base 2019.20191208-4
ii texlive-latex-extra 2019.20191208-1
ii texlive-latex-recommended 2019.20191208-4
ii unzip 6.0-25

Versions of packages auto-multiple-choice-common recommends:
ii fonts-linuxlibertine 5.3.0-4
pn libemail-address-perl <none>
ii libemail-mime-perl 1.946-1
pn libemail-sender-perl <none>
ii libfilesys-df-perl 0.92-6+b5
pn libnet-cups-perl <none>
pn libopenoffice-oodoc-perl <none>
ii libsys-cpu-perl 0.61-2+b5
ii pdftk 2.02-5+b1
ii pdftk-java [pdftk] 3.0.6-1
ii qpdf 9.1.0-1
ii sensible-utils 0.0.12+nmu1
ii texlive-xetex 2019.20191208-4

auto-multiple-choice-common suggests no packages.

-- no debconf information
Alexis Bienvenüe
2020-01-14 08:40:01 UTC
Reply
Permalink
Thanks for the report.
Post by Michal Sojka
I was able to get rid of it by manually installing
liblocale-codes-perl so I think that auto-multiple-choice-common
should depend on this package.
That looks strange because auto-multiple-choice-common already depends
Post by Michal Sojka
ii liblocale-codes-perl 3.62-1
Can you check that the installation ended properly when the problem
arose?

Regards,
Alexis Bienvenüe.
Michal Sojka
2020-01-14 13:10:01 UTC
Reply
Permalink
Post by Alexis Bienvenüe
Thanks for the report.
Post by Michal Sojka
I was able to get rid of it by manually installing
liblocale-codes-perl so I think that auto-multiple-choice-common
should depend on this package.
That looks strange because auto-multiple-choice-common already depends
Post by Michal Sojka
ii liblocale-codes-perl 3.62-1
I see. I generated the bug report after I installed the package manually
and that's why it was listed as dependency. If I uninstall
liblocale-codes-perl, the list of dependencies would look differently:

Versions of packages auto-multiple-choice-common depends on:
ii ghostscript 9.50~dfsg-5
ii imagemagick 8:6.9.10.23+dfsg-2.1+b2
ii imagemagick-6.q16 [imagemagick] 8:6.9.10.23+dfsg-2.1+b2
ii libarchive-zip-perl 1.67-1
ii libclone-perl 0.43-2
ii libdbd-sqlite3-perl 1.64-1+b1
ii libdbi-perl 1.642-1+b2
ii libfile-mimeinfo-perl 0.29-1
ii libglib-object-introspection-perl 0.048-1
ii libgraphics-magick-perl 1.4+really1.3.34+hg16181-1
ii libgtk3-perl 0.036-1
ii liblocale-gettext-perl 1.07-4
ii libperl5.22 [libio-compress-perl] 5.22.2-5
ii librsvg2-common 2.46.4-1
ii libtext-csv-perl 2.00-1
ii libxml-simple-perl 2.25-1
ii libxml-writer-perl 0.625-1
ii netpbm 2:10.0-15.3+b2
ii perl [libio-compress-perl] 5.30.0-9
ii perl-modules-5.22 [liblocale-codes-perl] 5.22.2-5
ii poppler-utils 0.71.0-6
ii tex-common 6.13
ii texlive-fonts-extra 2019.20191208-1
ii texlive-fonts-recommended 2019.20191208-4
ii texlive-latex-base 2019.20191208-4
ii texlive-latex-extra 2019.20191208-1
ii texlive-latex-recommended 2019.20191208-4
ii unzip 6.0-25

It can bee seen that liblocale-codes-perl is provided by
perl-modules-5.22. That's because perl-modules-5.22 has the following
dependencies:

Replaces: liblocale-codes-perl (<< 3.34)
Provides: liblocale-codes-perl
Breaks: liblocale-codes-perl (<< 3.34)

perl-modules-5.22 is a left-over package from older distributions (in
Aptitude marked as "Obsolete"). If I uninstall it, liblocale-codes-perl
is automatically installed and AMC works fine. So maybe, AMC should
depend on liblocale-codes-perl (>= 3.34).

Alternatively, conflicting with perl-modules-5.22 would also help, but
this might force users to uninstall all (obsolete) packages depending on
it, which is not good. So I guess the versioned dependency on
liblocale-codes-perl is a better solution.

Best regards,
-Michal
Alexis Bienvenüe
2020-01-14 15:10:02 UTC
Reply
Permalink
Post by Michal Sojka
perl-modules-5.22 is a left-over package from older distributions (in
Aptitude marked as "Obsolete"). If I uninstall it, liblocale-codes-
perl
is automatically installed and AMC works fine. So maybe, AMC should
depend on liblocale-codes-perl (>= 3.34).
Thanks: I understand now.
To avoid the same problem with perl 5.24 and 5.26, I will use >= 3.42

Regards,
Alexis Bienvenüe.

Loading...